Announcement

Collapse
No announcement yet.

Now the transmission causing problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Now the transmission causing problems

    I swear this 74 Newport doesn't like me. I was driving to work yesterday and I was almost there when the trans started making a metalic clanking sound. I had to manually shift the 727 to get it going and it still wasn't shifting well.
    http://img.photobucket.com/albums/v6...0/fba33781.jpg

  • #2
    Maybe the sprag broke??

    Comment


    • #3
      That doesn't sound good. Maybe Trannyman can offer some further advice.

      Comment


      • #4
        Or a broken gear set those are the two things that are crunchy!

        Comment


        • #5
          Originally posted by Bblock View Post
          That doesn't sound good. Maybe Trannyman can offer some further advice.
          Uh.... Not much to go off of. U-joints clank? Lots of things can go clank, If the planetary broke, it should stop moving, or ??? Could be a sprag?? Can you hold it a little closer to the computer?
          His car wasn't that fast, I caught him on the return road and passed him in the pits.
          2006 Dodge 2500 CTD


          Comment


          • #6
            If you put it in drive and give it gas it won't go. If I put it in 1st it will go with a little hesitation then a little hesitation when manually shifting into 2nd. When I finally shift to 3rd I have to let off the gas for it to go into gear.
            http://img.photobucket.com/albums/v6...0/fba33781.jpg

            Comment


            • #7
              Not sure sounds like the sprag and maybe other issues!
              Rebuild time??

              Comment


              • #8
                Make sure the kick down at the carb and tranny are free and set right, but it sure sounds like a lot bigger problem.

                Comment


                • #9
                  Originally posted by Nathan300 View Post
                  If you put it in drive and give it gas it won't go. If I put it in 1st it will go with a little hesitation then a little hesitation when manually shifting into 2nd. When I finally shift to 3rd I have to let off the gas for it to go into gear.

                  Raise it up, and take 20 minutes to pull the pan........you will have an better idea then!

                  The fluid needs to be changed anyway.................!!

                  Comment


                  • #10
                    Yea wont move without the sparg pulling into manual first applies the low band and it makes it hold!
                    I think? :-)

                    Comment


                    • #11
                      It's getting parted out. Floors and quarters rotted and chrome is toasted
                      http://img.photobucket.com/albums/v6...0/fba33781.jpg

                      Comment

                      Working...
                      X